AudioRealism Forum Index AudioRealism

 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Custom Tuning ABL Pro

 
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    AudioRealism Forum Index -> Technical Questions
View previous topic :: View next topic  
Author Message
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Wed Dec 27, 2006 6:33 pm    Post subject: Custom Tuning ABL Pro Reply with quote

Hello there. I have a problem with ABL Pro, I cannot seem to be able to use custom tuning files with it.

I have a tuning editor that is capable of exporting .tun files, and it seems compatible with the files used by abl pro, as if I import the standard files used by abl pro into the editor they show all the correct characteristics of the 12 TET tuning in the relevent boxes in the editor.

However, if I set abl pro to custom tuning mode and import a .tun file, it doesn't seem to actually affect the tuning. I've tried this with both the au and vst versions.

The tuning editor is the Lil Miss Scale Oven (www.nonoctave.com), and I am using a powerpc mac (10.4.Cool.

thanks in advance! mark.
Back to top
View user's profile Send private message
audiorealism
Site Admin


Joined: 13 Oct 2003
Posts: 3881

PostPosted: Wed Dec 27, 2006 9:38 pm    Post subject: Reply with quote

Hi,

The current version does not support .tun, instead it has a custom file format with the frequency of each note specified per line.
There is an update with .tun support on the way but there is no date set on the release yet.

Hope this helps..

--Mike
Back to top
View user's profile Send private message Send e-mail
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Wed Dec 27, 2006 9:53 pm    Post subject: Reply with quote

yeah that definitely helps. thanks very much!
Back to top
View user's profile Send private message
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Wed Dec 27, 2006 10:05 pm    Post subject: Reply with quote

actually I can't get that to work either. I've tried using a text file with the frequencies of each note per line, and with the extension .tun but I that doesn't seem to work either. Do the frequencies have to be in a specific range, or have a specific number of decimal points? Or perhaps I am doing something else wrong...

thanks again. mark
Back to top
View user's profile Send private message
audiorealism
Site Admin


Joined: 13 Oct 2003
Posts: 3881

PostPosted: Wed Dec 27, 2006 11:36 pm    Post subject: Reply with quote

What version of ABL Pro are you using? And what machine?
Back to top
View user's profile Send private message Send e-mail
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Wed Dec 27, 2006 11:53 pm    Post subject: Reply with quote

ibook g4 osx 10.4.8
1.0.36 au/vst
ableton live 6 (if that makes any difference)
Back to top
View user's profile Send private message
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Thu Jan 04, 2007 6:51 pm    Post subject: Reply with quote

any idea why it won't work then?
Back to top
View user's profile Send private message
audiorealism
Site Admin


Joined: 13 Oct 2003
Posts: 3881

PostPosted: Thu Jan 04, 2007 10:20 pm    Post subject: Reply with quote

Have you tried the latest versions?

http://www.audiorealism.se/universal_downloads.htm

--Mike
Back to top
View user's profile Send private message Send e-mail
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Fri Jan 05, 2007 2:05 am    Post subject: Reply with quote

Just tried with the newest version but no luck with that either I'm afraid.

If it's a lot of effort to get to the root of the problem you don't need to worry yourself on my behalf, I have other synths to mess around with for the time being. I understand that you have some important projects on the go and I wouldn't want to ruin your workflow.
Back to top
View user's profile Send private message
audiorealism
Site Admin


Joined: 13 Oct 2003
Posts: 3881

PostPosted: Fri Jan 05, 2007 11:04 am    Post subject: Reply with quote

Markb, I just confirmed that there is indeed a bug in loading the tuning files on the Mac versions.

You can download a fix here:

http://www.audiorealism.se/ablpro/ABLPro1103AU.zip

Drop the .components into /Library/Audio/Plug-Ins/Components

(Back up your old ABLPro .components first if you want).

Make sure the splash screen says 1.103 to make sure you got the right version.

This one will load the ABL Pro .tun files, that is with one frequency stated per MIDI note (check out standard.tun and test.tun in the ABL Pro Tunings directory). It should also be able to load scala files (.scl) however this is still untested.

Hope this helps..

--Mike
Back to top
View user's profile Send private message Send e-mail
markb



Joined: 08 May 2006
Posts: 8

PostPosted: Fri Jan 05, 2007 12:55 pm    Post subject: Reply with quote

works like a charm, thanks mike!

cheers, mark.
Back to top
View user's profile Send private message
Display posts from previous:   
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.    AudioRealism Forum Index -> Technical Questions All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group